Script Auto Login WMS Mikrotik Terbaru 2021

Daftar Isi [Show]

Pengguna WMS pasti tahu kalau memakai wifi venue tiap sehari sekali harus login ulang untuk bisa tersambung. Memang terlihat sepele kan?. Tinggal login sekali saja kok repot?. Iya kalau kalian hanya pengguna biasa seperti saya. Tapi bagaimana kalau kalian pemain RT RW NET?. Pasti menjengkelkan.

auto login wms mikrotik terbaru

Bayangkan kalau sedang keluar rumah sedangkan koneksi internet memerlukan login ulang. Para pelanggan pasti sudah mencak-mencak. Makanya untuk cari aman para pemain RT RW NET lebih memilih Indihome. Tapi sayang sekali Indihome menerapkan sistem FUP. Kalian tahu kan, pasti tiap mau akhir bulan koneksi lemot karena penggunaanya melebihi FUP.

Sebelum ini sih enak, masih ada SSID seamless@wifi.id. Tinggal konek dan tidur nyenyak. Tapi sungguh disayangkan, Telkom berniat menghapus SSID seamless@wifi.id ini.

Terus bisa tidak kita konek cuma sekali saja menggunakan SSID Venue?. Bisa dengan menggunakan script auto login.

Script Auto Login WMS Di Mikrotik

Ya kita harus menggunakan Mikrotik (kalau kalian sudah membaca artikel ini pasti sudah menggunakanya kan?). Jadi dengan script ini nanti setiap mikrotik diskonek, akan melakukan login ulang dengan sendirinya.

Silakan kalian copy script ini di notepad terlebih dahulu supaya mudah dalam pengeditan


# Daftar Variable
:local user "XXX"
:local pass "XXX"
:local gwid "XXX-XX-XXX"
:local ether "XXX"
:local wlan "XXXXXXXXXX/TLK-WIXXXXXXXX-000X:XXXXX"
:local wms "@wms.XXXXXXXXXX.000"
:local redirect "https://www.livescore.com"
# Akhir Variable

:log info "Menjalankan Auto Login ..."
:local ip [/ip address get [/ip address find interface="$ether"] address];
:local ip [put [:pick $ip 0 [:find $ip "/"]]];
:if ([:len $ip] = 0) do={
	:log error ("Interface $ether tidak mendapatkan alamat ip --- mencoba mendapatkan...");
	/ip dhcp-client release [find interface="$ether"];
};
delay 1s

:local mac [/interface get [find name="$ether"] mac-address];
:local gateway [/ip dhcp-client get [find interface="$ether"] gateway];
:log warning "IP Address     : $ip"
:log warning "MAC Address : $mac"
:log warning "IP Gateway    : $gateway"

:log info "Menghubungkan ..."

:local num1 [:pick [/system clock get time] 0] 
:local num2 [:pick [/system clock get time] 1] 
:local num3 [:pick [/system clock get time] 3] 
:local num4 [:pick [/system clock get time] 6] 
:local char1 [:pick "abcdefghijklmnopqrstuvwxyz" "$num1$num2"]
:local char2 [:pick "abcdefghijklmnopqrstuvwxyz" "2$num2"]
:local char3 [:pick "abcdefghijklmnopqrstuvwxyz" "1$num4"]
:local user "$user.$char3$char1$char2$wms"

:do {
	:tool fetch mode=https http-header-field="Content-Type: application/x-www-form-urlencoded; charset=UTF-8,User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36,Referer: https://welcome2.wifi.id/login/?gw_id=$gwid&client_mac=$mac&wlan=$wlan&sessionid=XXXXXXXXXXXXXXXX-XXXXXXXX&redirect=$redirect" http-method=post http-data="username=$user&password=$pass" url="https://welcome2.wifi.id/wms/auth/authnew/autologin/quarantine.php\?ipc=$ip&gw_id=$gwid&mac=$mac&redirect=$redirect&wlan=$wlan" dst-path=wms.txt;
	:if ([/ping address=$gateway interface="$ether" count=2] = 0) do={
		:log error "Login gagal... ";
		/ip dhcp-client release [find interface="$ether"];
	}
	:if ([/ping address=$gateway  interface="$ether" count=2] != 0) do={
		:log info "Login SUKSES..."
		:local iRes [/file get wms.txt contents];
		:log warning $iRes
		delay 1s
		:file remove wms.txt
	}
}
#:log warning "$user.$char3$char1$char2$wms"

Copy juga script schedule ini,


:if ([:ping 8.8.8.8 interface=XXX count=5]=0) do={:system script run wms;}

Cara edit Script Auto Login WMS

Sebelum memasang script autologin, kita edit terlebih dahulu script yang sudah di copy tadi.

  1. Sambungkan ke SSID Venue kalian
  2. Setelah konek dan masuk kehalaman login, jangan diloginkan dulu. Dihalaman login silakan tekan kombinasi CTRL+U atau bisa dengan cara Klik kanan dihalaman login dan pilih View page source. Nanti akan terbuka tab baru
  3. Silakan edit script
    :local user "XXX" : edit XXX dengan username login kalian
    :local pass "XXX" : edit XXX dengan password login kalian
    :local gwid "XXX-XX-XXX" : dihalaman yang terbuka saat CTRL+U silakan tekan CTRL+F dan ketikkan gwid nanti ganti XXX-XX-XXX dengan gwid kalian.
    :local ether "XXX" : edit dengan interface mikrotik wlan kalian yang untuk menangkap SSID venue. Misalnya punya wlan2
    :local wlan "XXXXXXXXXX/TLK-WIXXXXXXXX-000X:XXXXX" : sama seperti edit gwid, tekan CTRL+F dan ketikkan wlan
    :local wms "@wms.XXXXXXXXXX.000" : tekan CTRL+F dan ketikkan @wms nanti silakan ganti dengan @wms kalian
    :local redirect "https://www.livescore.com" : Tidak usah diedit, menurut saya yang paling cepat ya pakai situs ini.
    sessionid=XXXXXXXXXXXXXXXX-XXXXXXXX : ini didapat di alamat login wms kalian

    untuk edit script schedule
    :if ([:ping 8.8.8.8 interface=XXX count=5]=0) do={:system script run wms;} : silakan isi XXX dengan interface mikrotik wlan kalian yang untuk menangkap sinyal wifi.

Cara Memasang Script Auto Login Venue WMS Di Mikrotik

  1. Login ke winbox kalian
  2. Masuk ke System -> Scripts
    selanjutnya tekan tombol + dan masukkan scriptnya
    auto login wms mikrotik terbaru
    auto login wms mikrotik terbaru
    auto login wms mikrotik terbaru

  3. Jika sudah sekarang tinggal mengatur schedulenya dengan masuk System -> Schedule
    isikan seperti ini
    auto login wms mikrotik terbaru
    auto login wms mikrotik terbaru
  4. Selesai


Bagaimana?. Mudah kan untuk menerapkan script auto login venue wms di mikrotik?.

Newest Post
Comment Policy: Silahkan tuliskan komentar Anda yang sesuai dengan topik postingan halaman ini. Komentar yang berisi tautan tidak akan ditampilkan sebelum disetujui.
Buka Komentar
Tutup Komentar